Type Khmer Unicode on Microsoft Office Word on MacOS [Macbook]

I have spent a lot of time searching and trying and finally, I got an easy tip for you. It works for me and one friend of mine, so I hope it works for you too.

This is a quick video tutorial in Khmer (for you guy not Khmer, I have written a script where you can pause or just follow along with the movement).

[Fixed] Khmer font in Word on Mac

1. Install Khmer Unicode NiDA keyboard

Download and copy Khmer.keylayout to /Users/YourName/Library/Keyboard Layouts You may follow this guide

If you’re familiar with terminal, issue the following command to copy:

cp Where-You-Extra-To/Khmer.keylayout ~/Library/Keyboard\ Layouts/

Then, open “System Preferences“, search for “keyboard layouts“, click plus sign “+“, scroll down and select “Others“, you will see “NiDA Khmer“, select it and click “Add” and you’ve done!

2. Install more Khmer fonts

Download fonts here and extra it, then open “Font Bookwhere you can find by click on “Lauchpad” and search for “Font Book”, right click and choose “Add Fonts …” , browse to folder where you extracted your fonts to, select all, and click “Open” 

 

Note that some fonts will not display correctly, some of them I found work well are basically “Khmer OS …” font family. I would recommend you to select font before you start your typing 🙂

That’s it!!! Have fun!!! 🙂

Screen Shot 2018-01-03 at 3.11.51 PM

How to block using address-list in MikroTik

If you have multiple destination websites (addresses) you wish to block and you may want to add more addresses sometime in the future. It is a good idea to group those addresses into a list with a name that you can then block using that name. Time to time, you just need to add to the list without the need of writing a new blocking rules.

E.g. You want to block three websites e.g. a.com (122.3.2.1), b.com (100.1.2.3) and c.com (29.9.9.1). What you need to do is to issue: nslookup a.com … Or whatever way you do to get IP address of what websites (or anything?) you want to block. Then add the translated IP addresses into a list (let say name: BlockList). Finally, apply a firewall filter rule to block them with an action: reject or drop.

Here is how to do using command lines:

/ip firewall address-list add address=122.3.2.1 list=BlockList

/ip firewall address-list add address=100.1.2.3 list=BlockList

/ip firewall address-list add address=29.9.9.1 list=BlockList

/ip firewall filter add action=reject chain=forward dst-address-list=BlockList in-interface=lan out-interface=internet

… Later you can just add more address, last rule will automatically be applied. Note that you can also use this list to apply with other things like mangle…

How to remove page number from Heading 1 in Table of Contents [MS Word]

Here is what you do and come to problem:

1- Make sure you already set all heading for your titles (heading 1, 2 or 3)

2- Now it’s time that you insert your “table of contents”, but you don’t want to show page number on heading 1 (heading 1 for Part I, Part II … as shown in the figure 2 below)

Here is the solution:

  • Insert your table of content
  • Press Alt+F9 to switch between your normal table of content and TOC mode.
  • You should see { TOC \o “1-3” \h \z \u }. 
  • Then change it to { TOC \n “0-1” \h \z \u } to remove page number from heading 1 but NOT for others. (refer to figure 1)
1

Figure 1: when pressing Alt+F9

 

2

Figure 2: your desired table of contents

3

Figure 3: How you set auto numbering different level

 

How to install and access to your Raspberry Pi (Rasbian Lite version — No GUI)

Teamviewer on rasbian lite (no GUI)

  1. make sure you have TeamViewer account
  2. Download package: $ wget https://download.teamviewer.com/download/linux/teamviewer-host_armhf.tar.xz
  3. Extract package: $ tar -xvf teamviewer-host_armhf.tar.xz
  4. Install via dpkg tool: $ dpkg -i teamviewer-host_armhf.deb
  5. Run apt to fix: $ apt install -f (then you will ask to install a lot of dependencies, by issue ‘Y’)
  6. Run this command: $ teamviewer setup -> accept agreement -> login your credential (email) -> go to your
  7. email and add trusted devices -> you should get your TeamViewer ID for your raspberry box
  8. Create password for your device corresponding to your TeamViewer ID you get from the previous step: $ teamviewer –passwd YOUR_PASSWORD

===> Now you should be able to log in to your raspberry pi via teamviewer shown as SSH console.

 

Screen Shot 2017-12-07 at 4.40.20 PM

Sample image: Raspberry Pi from TeamViewer Apps with ‘htop’ running

 

How to install Webmin in Ubuntu

Here are a couple steps to get Webmin up and running on Ubuntu box:

  1. Make sure you log in as root, otherwise issue: sudo -s
  2. Add *.list file name webmin.list: nano /etc/apt/sources.list.d/webmin.list
    #add this lines
    deb http://download.webmin.com/download/repository sarge contrib
    deb http://download.webmin.com/download/repository sarge contrib
  3. Download key file: wget http://www.webmin.com/jcameron-key.asc
  4. Add key: apt-key add jcameron-key.asc
  5. Update package list: apt-get update
  6. Install package Webmin: apt-get install webmin
  7. Finally, you can now access to your Ubuntu box: https://Ubuntu-IP-Address:10000

Cheers!!!

Setup Docker container for GNS3

To get started, make sure you have:
– GNS3 installed and GNS3 VM setup (see this link: http://docs.gns3.com/1wdfvS-OlFfOf7HWZoSXMbG58C4pMSy7vKJFiKKVResc/)
– Internet connection required!!!
– For my case, I work on Mac. It might not much different on other platforms.

To add container, let say ‘ipterm’, follow these steps:

gns3->preferences->docker containers->new->run this docker vm on the gns3 vm->new image:gns3/ipterm->name:gns3-ipterm->adapters:1->start command: -> console type:telnet->finish

***for Ubuntu, you may say ‘gns3/ubuntu:xenial’